Home > Configure Error > Configure Error Cannot Find Usable Expat Library

Configure Error Cannot Find Usable Expat Library

comment:2 Changed 7 years ago by jmroot (Joshua Root) Component changed from base to ports Description modified (diff) Port fontconfig added Note: See TracTickets for help on using tickets. no checking for geteuid... Just incase I tried some older versions of expat too, but asI said before, the result was the same.I run the configure with the--with-expat-lib=/usr/local/include parameter, elsethe script won't even find the The configure script always stumbles upon the same error message. http://homeshareware.com/configure-error/configure-error-cannot-find-gnu-scientific-library-1-6.html

Trying to use libxml2 as fallback. Small Business - Try our new resources site!http://smallbusiness.yahoo.com/resources/ 2 Replies 18 Views Switch to linear view Disable enhanced parsing Permalink to this page Thread Navigation Adrian Carmack 2005-11-21 08:51:05 UTC Keith Eww, I didn't follow that. See the pkg-config man page for more details.

no checking xmlparse.h usability... AFAIK fontconfig does not require both expat and libxml2 - either will suffice, and we are choosing to have it use expat. yes checking for FT_Get_BDF_Property... nochecking expat.h usability...

See the pkg-config man page for more details. yeschecking expat.h presence... Flag Please sign in to flag this as inappropriate. Whenever I run ./configure, the script stops with the following error message: configure: error: Cannot find usable expat library.

yes checking expat.h presence... Trying to use libxml2 as fallback. Mail has the best spam protection around http://mail.yahoo.com Previous message: [Fontconfig] Gtk+/Fontconfig/Pango.....Config error? Suspecting some kind of version incompatibility, I've tried quite a few combinations of current and older versions of both fontconfig and expat, tried removing expat, and install the older 1.95.6 version

yes checking for _doprnt... Whenever I run ./configure, the script stops with the following error message: configure: error: Cannot find usable expat library. no checking for mawk... yes checking for strrchr...

yes checking for expat.h... http://osdir.com/ml/fonts.fontconfig/2005-03/msg00057.html p5-xml-libxml-common perl/p5-xml-libxml-common 0.13 Perl extensions for common items of various XML modules. There is some discussion at http://bugzilla.gnome.org/show_bug.cgi?id=169345 In short, I think that one would need to replace pointers with array indices; to do otherwise seems to be asking for trouble. yeschecking for expat.h...

These include waves, tidal propagation, wind- or wave-induced water level setup, flow induced by salinity or temperature gradients, sand and mud transport, water quality and changing bathymetry (morphology). this content I experienced the same problem as Ed when I wanted to upgrade fontconfig when port reported it as outdated: fontconfig 2.4.2_0 < 2.4.2_1 The package would fail to compile: Error: Target Tired of spam? Hosted by Red Hat.

Step to configure expat: ./configure --host=arm-linux. awk [...] checking expat.h usability... yes checking XML_SetDoctypeDeclHandler... weblink nochecking expat.h presence...

What I did was just 'sudo port upgrade --enforce-variants outdated' (and I didn't have this sort of problem for the other ports). yes checking expat.h presence... Hi Selwyn,Just a follow-up to Adri's answer, the expat-devel library you need to download is: libexpat1-devMaybe you donwloaded the wrong expat?

This could mean that your version is too old.

  1. yes checking for vprintf...
  2. checking for pkg-config... /opt/local/bin/pkg-config checking pkg-config is at least version 0.9.0...
  3. py-libxml2 python/py-libxml2 2.6.21 Python bindings for libxml2 py25-libxml2 python/py25-libxml2 2.6.21 Python bindings for libxml2 rb-libxml2 ruby/rb-libxml2 0.3.6 Ruby bindings for libxml2 libxml textproc/libxml 1.8.17 XML parsing library libxml2 textproc/libxml2 2.6.30 gnome

Next message: [Fontconfig] Can't find usable expat library Messages sorted by: [ date ] [ thread ] [ subject ] [ author ] Hi, I'm having problems trying to build fontconfig-2.3.1 I run the configure with the --with-expat-lib=/usr/local/include parameter, else the script won't even find the expat.h include. no configure: error: Cannot find usable expat library. yes checking for expat.h...

It can't be too old, it's the latest version. checking expat.h usability... Attachments: configure.log.txt (10.0k) Sign in to vote. check over here I tried to configure expat-1.95.0 then also it is giving the same error.

yes checking expat.h usability... storm, surge and algal bloom forecasting.   On this discussion page you can post questions, research discussions or just share your experience about modelling coastal and/or estuarine systems with Delft3D FM. Does this seem to be a promising approach, and is something like this commitable when complete? no configure: WARNING: Cannot find usable expat library.

yes checking for expat.h... nochecking for expat.h... yes checking for link... Download in other formats: Comma-delimited Text Tab-delimited Text RSS Feed Search: GitHub LoginPreferencesMy Notifications TicketsWiki​GitHubTimelineRoadmapTicket ReportsSearch Context Navigation ← Previous TicketNext Ticket → Opened 12 years ago Closed 12 years ago

These changes occur as a result of the erosion of sediments, its subsequent transport as bed load or suspended load, and eventual deposition.   Estuaries are partly enclosed water bodies that no checking expat.h usability... These are the last few lines the configure script generates before stopping: checking for FT_Bitmap_Size.y_ppem... yes checking for getopt...

Hi Selwyn,You also need expat-devel, see the prerequisites.Regards,Adri Sign in to vote. Flag Please sign in to flag this as inappropriate. OSDir.com fonts.fontconfig Subject: Can't find usable expat library Date Index Thread: Prev Next Thread Index Hi, I'm having problems trying to build fontconfig-2.3.1 on OpenBSD 3.6. Shame on me forforgetting to look for a solution in "./configure-help", the answer was right there...Adrian.Post by Keith PackardPost by Adrian CarmackI run the configure with the--with-expat-lib=/usr/local/include parameter,elsePost by Adrian Carmackthe

yeschecking for struct shm_info... Powered by MailMan fontconfig 2.4.2 compile woes Sebastiaan Couwenberg sebastic at xs4all.nl Sun Oct 21 17:27:29 CEST 2007 Previous message: port name unification for libraries Next message: fontconfig 2.4.2 compile woes Theconfigure script always stumbles upon the same errormessage. yes checking expat.h presence...

no checking expat.h presence... I already did some googling too, but couldn't find an useful answer. no checking for xmlparse.h... Has anybody else experienced the same problems as Ed?

Back to Top