Home > Configure Error > Configure Error Cannot Link With The Boost Thread Library

Configure Error Cannot Link With The Boost Thread Library

yes checking for gcc option to accept ISO C89... yes > checking whether the Boost::Thread library is available... no checking whether pthreads work with -pthread... more hot questions question feed lang-c about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation http://homeshareware.com/configure-error/configure-error-cannot-find-gnu-scientific-library-1-6.html

checking for boostlib >= 1.37... yes checking for poll.h... ADD REPLY • link written 5 months ago by cagolino • 0 0 14 months ago by Philipp Bayer ♦ 3.7k Australia/Perth/UWA Philipp Bayer ♦ 3.7k wrote: Hello, I just ran Query for highest version Display field value in Drop Link field How can I take a powerful plot item away from players without frustrating them? http://askubuntu.com/questions/420100/pov-ray-installation-configure-error

yes checking whether to build static libraries... Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox. no > configure: error: in `/home/rakshasa/Downloads/tmp/povray-3.7.0.RC7': > configure: error: cannot link with the boost thread library > See `config.log' for more details > > I am running XUbuntu 13.10 x64 on

  1. yes checking if g++ static flag -static works...
  2. linux boost debian share|improve this question edited Feb 23 '13 at 22:44 Tshepang 4,7161059103 asked Feb 3 '12 at 16:54 ReZa 5441819 3 Do you have something like libboost-system1.46.1 installed
  3. o checking whether we are using the GNU C compiler...
  4. yes checking return type of signal handlers...
  5. share|improve this answer answered Jan 25 '15 at 3:09 Mo2 1632416 add a comment| up vote 0 down vote To avoid OpenSSL issues you can build "libtorrent-rasterbar" disabling OpenSSL encryption.
  6. Seipas commented Feb 21, 2016 It seems to work, I was able to build and to render scenes/lights/arealit3.pov Thank you !

Greenfoot Username Password Remember Me? Although this is old post, hope it will help someone else like me. gcc checking whether the C compiler works... yes checking for sys/param.h...

yes checking for vfork... Thank you for your help. yes checking whether g++ accepts -g... More Bonuses a.out checking for suffix of executables...

no checking whether the compiler implements namespaces... I can go ahead one more step follow up above suggestion. yes checking if libtool supports shared libraries... no configure: error: in `/home/seipas/Téléchargements/povray-3.7-stable': configure: error: cannot link with the boost thread library config.log : configure:7100: checking whether pthreads work with -pthread configure:7183: gcc -o conftest -pthread conftest.c >&5 conftest.c:

no checking whether to enable static linking... It appears to me to be a configure bug. I'm trying to install Tophat. no > checking whether to build the boost thread library from sources...

yes checking for strings.h... this content no configure: error: wxWidgets must be installed on your system. The error is: autoreconf -i glibtoolize: putting auxiliary files in `.'. yes checking for stdlib.h... (cached) yes checking sys/param.h usability...

yes checking for working alloca.h... yes checking for sys/stat.h... yes checking for g++... weblink g++ checking whether we are using the GNU C++ compiler...

DomT4 commented Jan 6, 2016 Was fixed by 9ee68c8. no > checking whether pthreads work without any flags... yes checking for a thread-safe mkdir -p... /bin/mkdir -p checking for gawk...

checking for pkg-config... /usr/bin/pkg-config checking for openssl/ssl.h in /usr/local/ssl...

configure:4667: $? = 4 configure:4656: gcc -qversion >&5 gcc: error: unrecognized option '-qversion' gcc: fatal error: no input files compilation terminated. yes checking sys/socket.h presence... no checking for openssl/ssl.h in /usr/local... Home Hall of Fame Groups Digests Personalise Search POV-Ray: Newsgroups: povray.unix: Cannot compile 3.7 on XUbuntu 13.10 x64 ServerTime: 8Nov201616:25:25GMT Cannot compile 3.7 on XUbuntu 13.10 x64 (Message 1 to 5

configure: error: We could not detect the boost libraries (version 1.35 or higher). The output from the terminal, and config.log are located here: https://gist.github.com/j6thomps/602147d1c016fa2fa349. Can I cite email communication in my thesis/paper? check over here no checking whether pthreads work without any flags...

You signed out in another tab or window. Terms Privacy Security Status Help You can't perform that action at this time. no checking whether to build the boost thread library from sources... Not the answer you're looking for?

no > checking for boostlib >= 1.35... Not the answer you're looking for? yes checking for int32_t... I tried every answer from this page but only this worked for me.

Namely : ./configure COMPILED_BY="..." LIBS="-lboost_system -lboost_thread" Does this work for you? It seems you now need libusb instead of libusb-devel, and for Boost I ended up having to hardcode my boost paths! Those tended to be less troublesome for us. yes checking sys/param.h presence...

Then I made sure ldconfig saw /usr/local/lib. no checking for openssl/ssl.h in /usr/lib/ssl... yes checking for exit in -llib...

Back to Top